Locked History Actions

Diff for "ListOfPackages"

Differences between revisions 1 and 14 (spanning 13 versions)
Revision 1 as of 2008-03-03 13:07:06
Size: 703
Comment:
Revision 14 as of 2015-03-16 12:33:17
Size: 810
Comment:
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
= List of Necessary Packages = = List of Required Packages =
Line 5: Line 5:
 * [http://numpy.scipy.org/ NumPy]
 * [http://www.scipy.org/ SciPy (Scientific Tools for Python)]
 * [http://matplotlib.sourceforge.net/ Matplotlib]
 * [http://download.dezentral.de/soft/Python/Polygon/ Polygon]
 * [http://www.egenix.com/products/python/mxBase/mxDateTime/ mxDateTime]
 * [http://www.reportlab.org/pyrxp.html pyRXP]
 * [http://www.cdc.noaa.gov/people/jeffrey.s.whitaker/python/gmt/gmt-src/doc/html/public/gmt.gmt-module.html gmt.gmt]
 * [[http://numpy.scipy.org/|NumPy]]
 * [[http://matplotlib.sourceforge.net/|Matplotlib]]
 * [[http://pypi.python.org/pypi/Shapely/|Shapely]] (Requires libgeos_c. Note: Shapely 1.2.1 requires libgeos_c >= 3.1. If your system has an older version of libgeos_c, use Shapely version 1.0.15)
 * [[http://www.egenix.com/products/python/mxBase/mxDateTime/|mxDateTime]]
 * [[http://www.reportlab.com/ftp/|pyRXP]] (use version 1.x, NOTE: 2.x series does not work)
 * [[http://codespeak.net/lxml/|lxml]] (version >= 2.0, need target parser)
Line 13: Line 12:
== External Tools == == Other Packages ==
Line 15: Line 14:
 * [http://gmt.soest.hawaii.edu/ GMT (Generic Mapping Tools)]  * optional: working [[http://gmt.soest.hawaii.edu/|GMT]] installation for some plots
Line 19: Line 18:
 * [http://ipython.scipy.org/moin/ IPython (Enhanced Python Shell)]  * [[http://ipython.scipy.org/moin/|IPython]] (Enhanced Python Shell)

List of Required Packages

Python Packages

  • NumPy

  • Matplotlib

  • Shapely (Requires libgeos_c. Note: Shapely 1.2.1 requires libgeos_c >= 3.1. If your system has an older version of libgeos_c, use Shapely version 1.0.15)

  • mxDateTime

  • pyRXP (use version 1.x, NOTE: 2.x series does not work)

  • lxml (version >= 2.0, need target parser)

Other Packages

  • optional: working GMT installation for some plots